PHP is amongst the most commonly used curly-bracket programming languages. It is highly popular since it is free software, which can be used to develop interactive websites like community sites, Internet shops or online teaching websites as opposed to static HTML sites. A PHP module should be present on the web server where a PHP-driven website is hosted so that its code can be read. Because there aren’t any license charges for this type of module and the language itself offers innumerable possibilities for the web applications that you build, there’re 100s of millions of PHP-powered sites. What is more, there’re a myriad of PHP-based scripts, which you can use for your websites without needing to have any programming expertise. Considering the fact that there are several PHP versions, you should confirm if the same exact version that you used while setting up your site is enabled on the web server too.
PHP 4 and PHP 5 Support in Cloud Hosting
With our cloud hosting, you’ll be able to select the version of PHP that will be active for your hosting account, since multiple versions are supported on our servers. With only one click of the mouse, you’ll be able to switch between PHP 5.5, 5.4, 5.3, 5.2 and 4 and whenever a new version is unveiled in the future, we’ll add it to the Hepsia hosting Control Panel without removing the older ones. Thus, you’ll be able to host all the websites that you have developed throughout the years. In stark contrast to a lot of other hosting providers, we won’t compel you to update such sites, because a script may be outdated, but this does not mean that it is insecure as you may have done modifications to its code to fill security loopholes. For your convenience, you will even be able to choose a different version of PHP for each site that you host in your shared hosting account.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
Even in case your sites were created with an earlier version of PHP, you’ll be able to host them in a semi-dedicated server account from us, as we support several versions running simultaneously on our servers and each one of them can be activated for your account with just a click through our in-house created Hepsia hosting Control Panel. Other than the newest PHP 5.4 and PHP 5.5, we also offer 5.3, 5.2 and the older PHP 4. The latter has already been abandoned by the great majority of web hosting vendors, but we strongly deem that you shouldn’t be forced to modify a site that took several years to build, as older script language syntax does not necessarily suggest security weaknesses. Just the opposite, an adequately maintained website using PHP 4 can be more reliable than a non-maintained one using PHP 5. For the sake of your convenience, we will also offer you the opportunity to select a different PHP version for each individual site within your account.